Jump to content

Ack! The dock shows and interrupts gameplay.

Recommended Posts

Ok guys. I'm having a bit of a problem with RK Launcher (build 149). First let me praise the author for the work, as it is simply the best dock I have ever used. Thank you, sir! :cool:

Now my question:

How can I make the dock only appear whenever the XP taskbar is showing? My problem is the dock pops out and minimizes my games, which I do not want to happen. (I have the dock set automatically hide.) I see there is two options to combat this situation. "always on top", and "use margin hotspot".

With both the options unchecked, the dock doesn't pop out during game play (a good thing :D ), but then again, if I maximize Firefox or an Explorer window, the dock doesn't pop out either (a bad thing :( ).

With just "use margin hotspot" checked, the dock always pops out, but even during game play, so it minimizes the game and goes back to the desktop to show the dock (a bad thing :( ).

With just "always on top" checked, I get the same results as above, which makes me wonder what is the difference between the two options.

So again, is there a way to make the dock only show if one can see the taskbar? Maybe there can be an option under the "Exclusions" tab to make the dock not appear if an added application has focus. A new type called "Do not allow dock to show when these applications have focus".

I don't know... any suggestions for me?

Link to comment

Unchecking both "Automatically hide" and "use margin hotspot" fixes it good for the games... But I do not want the dock to always be showing on the desktop. I want it to auto hide. I just don't want it showing when my desktop isn't showing. If it is not possible to check if the desktop is showing before showing the dock, an Exclusions list is a good idea.

Link to comment
"Quit the dock" does it for me...

(yes I know this isnt what you want, but I just wanted to point out that that was a possibility)

Lame! That is not the solution to this. You don't want to have to disable your dock beforehand; you would want to launch the game from your dock. :mad:

@HELLFISH: which game(S) get skrewed by RKLauncher?

Personally I had trouble with both Shogun: Total war & Medieval: Total War, Rainbow6 3 & Swat4. All of these got solved (for me) by unchecking use margin hotspot.

Link to comment
When Always on top is checked it never goes away and you can always see it

when use margin hotspot is checked it doesn't show but when you go on top of the dock even though it doesn't show it will appear.

that's accurate ;)

if you uncheck both 'automaticaly hide' and 'use margin hotspot' all your games should work fine.

Link to comment
cool docklet. is there a universal program like that? that would be awesome. close objectbar, entbloess, rklauncher, avedesk, desktop x, and msn automatically when playing a game for full smooth experiance. helps games run faster too.

Well, i know this is slightly going off the topic a bit, but always glad to help :)

@ Steelfist - Why don't you run a script b4 playing games that's what i do, open notepad and save the following as a bat file (.bat). Change with what u wanna stop/start and then execute the bat file.

B4 Playing Games:

NET STOP "Automatic Updates"

NET STOP "Cryptographic Services"

NET STOP "Diskeeper"

NET STOP "Print Spooler"

NET STOP "Shell Hardware Detection"

NET STOP "Task Scheduler"

taskkill /f /im objectdock.exe

taskkill /f /im AveDesk.exe

taskkill /f /im sdmcp.exe

taskkill /f /im wfxload.exe

taskkill /f /im iTunes.exe

taskkill /f /im wmiprvse.exe

After Playing games

NET START "Automatic Updates"

NET START "Cryptographic Services"

NET START "Diskeeper"

NET START "Print Spooler"

NET START "Shell Hardware Detection"

NET START "Task Scheduler"

Start "ObjectDock" "C:Program FilesStardockObjectDockObjectDock"

Start "WinFX" "C:Program FilesStardockWindowFXwfxload"

Start "AveDesk" "C:Program FilesMac XtraAveDeskAveDesk"

taskkill /f /im wmiprvse.exe

Rest of the services i haven't listed as i already turned off :P

Sorry for long post :P

Link to comment

Thank you for the reply. Maybe I am just not getting it, but if I uncheck "use margin hotspot" like you suggest, then the dock will not fly out if an application is maximized. Note that there is a difference between a fullscreen game, and a maximized window. I would want the dock to show during a maximized firefox session, but not during a fullscreen game.

This doesn't seem possible at the present time. Refer to my original post for explicit details on what happens with various boxes checked and unchecked.

Link to comment

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...