Jump to content

Cursor Error

Recommended Posts

Hi guys,

I've been working for a few days on a Leopard transformation kit, and I've reached a dead end. I have tried several shell32.dll files, and all is great apart the cursor used when you create a shortcut or copy a file (arrow and +) that have a black border. I will post a screenshot to better explain myself. Another issue is that some of the icons don't show up even after rebuilding (like connection icon). Anyways, the cursor problem is the one really bothering me. I have tried this on several systems, all have the same problem. It is a transparency issue, the black should be invisible. I have nvidia GC on all systems. Thank you.

Switching to 16bpp colormode solves the transparency bug but icons get really ugly. I need another way. I'd like to use reshack to replace those icons but i'm having trouble finding them.


Edited by boglav
Link to comment

What cursor editor are you using?

Have you tried AniFX? (http://icofx.ro/anifx/index.html)

BTW the shortcut black background is because you must define the mask correctly in the corresponding bitmap on shell32.dll, it is a bitmap twice tall than wide, with upper half the picture and lower half the mask (black is opaque and white is transparent if I remember right).

If you did define the mask then maybe post the picture (I mean extract the resource from shell32 and post it here as an attachment or link to download) to know what's going on...

My shell32.dll is customized by Flyakite (it doesn't replace shell32 but just it's icons, so it is Windows language independent, indeed mine is in spanish and had no problems), and the cursor plus shortcut overlay looks right here. If you want I can post a copy of my shell32, so you can test it, what do you think?

Link to comment


Installing Flyakite doesn't do the same. It doesn't use replacer.

I know this because else parts of my Windows would be in english (and everything is in spanish yet, so...) :P


I'm really surprised... after a bit of investigation on my part, I discovered that Flyakite happens to use... Resource Hacker! so:

1. It doesn't use replacer (which would revert service packs and change language strings, very undesirable effects).

2. It calls reshacker.exe with command line arguments (download Resource Hacker yourself and click Help > Contents > Commandline Scripting... if you happen to have Flyakite, the version it uses doesn't include the help file so that's why you have to download it yourself from Resource Hacker's official site instead).

So, a recommendation for anyone making customization packages: please use reshacker scripting, if you don't know how then just PM me and I'll be glad to help.


Ok, so let's see. Download Resource Hacker, open C:\windows\system32\shell32.dll with it and find Bitmap > 142 and Bitmap > 143, with each one right click the green gear icon and choose Save [ Bitmap : xxxx : yyyy ] and save both and post them here. I can put them in my own shell32 and tell if they work or not (and maybe even correct them).

BTW I'm posting my bitmaps if you want to compare/try to replace them into yours and see if they work:



Link to comment

I attached the files as you suggested. However, I suspect the problem being elsewhere, because:

I installed Flyakite (first shell32 only, then the rest of the dll's, OCX's, etc.) - problem;

I downloaded already modded shell32.dll (3 different versions) files and used replacer (successfully I guess, because i get all the icons)and installed them onto fresh copies of Windows (XP Pro, SP3) - the isssue remain.

I have done this on 2 different systems, laptop and desktop, both using Nvidia Graphic cards and different sets of drivers.



Link to comment

Mmm... your bitmaps seem right, I'll try them and see what happens.


Ok, not only your bitmaps are right, they are exactly the same to mine, and by the same I mean exactly the same files... :)

So there's something else wrong there. Maybe you should try to recover the original shell32.dll files for each machine (from Windows XP install disc) then try using reshacker instead of replacer.

Well... not exactly, let's see:

If I understood right, you're downloading other shell32.dll files and replacing yours with them. They may be from different service packs, versions, or whatever, and maybe the problem is there. Maybe you need to use the reshacker technique instead, by following these steps:

1. Make a copy of the original shell32.dll file.

2. With reshacker, replace the bitmaps and icons on the copy (you would be unable to do that with the original, because it is being used by the system).

3. Now tell replacer (yeah you still have to use replacer) to replace the original with the modified copy.

4. Finally restart the system or whatsoever.

If you're writing a transformation pack, you can always script on reshacker too, it is a bit more complicated because you have to write a line for each bitmap and icon you want to replace and... hey... that looks like an idea for a new software... a reshack script generator! maybe with multiple output options... bat file... exe file... nsis code... ahk code... :)

Link to comment
  • 2 months later...
  • 3 months later...
To fix this go to the "Display Properties" window> "Settings" tab> "Advanced" button> "Troubleshoot" tab, and drag the slider once to the left (then apply the changes, of course). That way it should be fixed.

"disable cursor and bitmap acceleration" - doesn't that affect system performance? As in 3d gaming and whatnot?

Link to comment
"disable cursor and bitmap acceleration" - doesn't that affect system performance? As in 3d gaming and whatnot?

I don't know about the games... but this affects the photoshop cs4, (not cs3), it leaves traces on the cs4 screen.

Edited by prcmelo
Link to comment

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...